This may be because your recording has to be scaled down to fit into the Player window, which can make it look worse than it really is.

If you go to View -> Movie Size and see that the 'Fit' option is selected, try selecting '100%' instead, which will show the recording at its true size and image quality.